カテゴリー「VMware Workstation Pro」の22件の記事

FreeNAS 11 : ZFS ストレージプールの作成 (VMware Workstation 14 Player)

接続されている物理ディスクを使用して ZFS ストレージプールを作成します。

[Storage] - [Volumes] を開く → [Volume Manager]ボタンをクリック


[Volume Name]にZFSストレージプール名を入力 → [Available disks]内の[+]をクリック → FreeNASの推奨構成を表示 → [Add Volume]ボタンをクリック


ZFS ストレージプールの作成中


ZFS ストレージプールの作成終了



【参考】
FreeNAS(R) 11.0-U4 User Guide

VyOS : 設定のまとめ2(VMware Workstation 12 Pro)

ここまでの VyOS の設定のまとめです。


set interfaces ethernet eth0 address dhcp
set interfaces ethernet eth0 description 'OUTSIDE'
set interfaces ethernet eth1 address '10.1.0.1/24'
set interfaces ethernet eth1 description 'INSIDE'

set system host-name gw set system domain-name exam.local

set service ssh port '22'

delete system ntp server 0.pool.ntp.org delete system ntp server 1.pool.ntp.org delete system ntp server 2.pool.ntp.org set system ntp server ntp.nict.jp set system time-zone Asia/Tokyoset interfaces ethernet eth0 address dhcp set interfaces ethernet eth0 description 'OUTSIDE' set interfaces ethernet eth1 address '10.1.0.1/24' set interfaces ethernet eth1 description 'INSIDE'

set system host-name gw set system domain-name exam.local

set service ssh port '22'

delete system ntp server 0.pool.ntp.org delete system ntp server 1.pool.ntp.org delete system ntp server 2.pool.ntp.org set system ntp server ntp.nict.jp set system time-zone Asia/Tokyo

set service dhcp-server disabled 'false' set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 default-router 10.1.0.1 set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 dns-server 10.1.0.101 set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 domain-name exam.local set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 lease 86400 set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 start 10.1.0.192 stop 10.1.0.254

set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 static-mapping ad1 ip-address 10.1.0.101 set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 static-mapping ad1 mac-address 00:50:56:39:78:6E set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 static-mapping nas1 ip-address 10.1.0.111 set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 static-mapping nas1 mac-address 00:50:56:22:8F:D9 set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 static-mapping esxi1 ip-address 10.1.0.122 set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 static-mapping esxi1 mac-address 00:50:56:34:9E:C3 set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 static-mapping esxi2 ip-address 10.1.0.123 set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 static-mapping esxi2 mac-address 00:50:56:2F:E3:4A

set service dns forwarding listen-on eth1

set nat source rule 100 outbound-interface eth0 set nat source rule 100 source address 10.1.0.0/24 set nat source rule 100 translation address masquerade

set firewall name OUTSIDE-IN default-action drop set firewall name OUTSIDE-IN rule 10 action accept set firewall name OUTSIDE-IN rule 10 state established enable set firewall name OUTSIDE-IN rule 10 state related enable

set firewall name OUTSIDE-LOCAL default-action drop set firewall name OUTSIDE-LOCAL rule 10 action accept set firewall name OUTSIDE-LOCAL rule 10 state established enable set firewall name OUTSIDE-LOCAL rule 10 state related enable set firewall name OUTSIDE-LOCAL rule 20 action accept set firewall name OUTSIDE-LOCAL rule 20 icmp type-name echo-request set firewall name OUTSIDE-LOCAL rule 20 protocol icmp set firewall name OUTSIDE-LOCAL rule 20 state new enable set firewall name OUTSIDE-LOCAL rule 30 action accept set firewall name OUTSIDE-LOCAL rule 30 destination port 22 set firewall name OUTSIDE-LOCAL rule 30 protocol tcp set firewall name OUTSIDE-LOCAL rule 30 state new enable

set interfaces ethernet eth0 firewall in name OUTSIDE-IN set interfaces ethernet eth0 firewall local name OUTSIDE-LOCAL


VyOS : DHCP で配布する DNS サーバーのIPアドレスの変更(VMware Workstation 12 Pro)

Windows Server 2016 に Active Directory をインストールするときに DNS サーバーを構築しました。DHCP サーバーから IP アドレスを払い出すときの DNS サーバーの IP アドレスを Windows Server 2016 の IP アドレスに変更します。今回の設定項目です。


コマンド実行結果

vyos@gw:~$ configure
[edit]
vyos@gw# delete service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 dns-server 10.1.0.1
[edit]
vyos@gw# set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 dns-server 10.1.0.101
[edit]
vyos@gw# commit
[edit]
vyos@gw# save
Saving configuration to '/config/config.boot'...
Done
[edit]
vyos@gw# exit
exit
vyos@gw:~$


変更前


変更後



【参考】
vyos-users.jp - ユーザーガイド - DHCP Server

Windows Server 2016 : Active Directory のインストール(VMware Workstation 12 Pro)

Windows Server 2016 に Active Directory をインストールします。インストール時に DNS サーバーのインストールも行われますが正引きだけなので、逆引きの設定も併せて行います。

サーバーマネージャーのダッシュボードで[2 役割と機能の追加]をクリック


[次へ(N)]をクリック


[役割ベースまたは機能ベースのインストール]を選択 → [次へ(N)]をクリック


[サーバープールからサーバーを選択]を選択 → [サーバープール]内からインストール先のコンピューターを選択→ [次へ(N)]をクリック


[Active Directory ドメインサービス]をチェック


[管理ツールを含める(存在する場合)]をチェック → [機能の追加]をクリック


[次へ(N)]をクリック


[次へ(N)]をクリック


[次へ(N)]をクリック


[インストール(I)]をクリック


インストール中


[このサーバーをドメインコントローラーに昇格する]をクリック


[新しいフォレストを追加する(F)]を選択 → [ルートドメイン名(R):]にドメイン名を入力 → [次へ(N)]をクリック


ディレクトリサービス復元モード(DSRM)のパスワードを[パスワード(D):]と[パスワードの確認入力(C):]に入力 → [次へ(N)]をクリック


[次へ(N)]をクリック


必要に応じて[NetBIOSドメイン名:]を変更(デフォルトはドメイン名の最初の部分) → [次へ(N)]をクリック


[次へ(N)]をクリック


[次へ(N)]をクリック


[インストール(I)]をクリック


インストール中


[閉じる(C)]をクリック


再起動中


[Ctrl] + [Alt] + [Del]を押してロックを解除


管理者 : Administrator のパスワードを入力してサインイン


サーバーマネージャーが自動起動:左側のメニュー内に [AD DS] と [DNS] が追加されていることを確認


[ツール(T)]をクリック → [Active Directory ユーザーとコンピューター]をクリック


左側のペインでドメイン名 exam.local を展開 → [Domain Controllers]をクリック → 右側のペインでコンピューター名を右クリック → [プロパティ(R)]をクリック


[全般]タブで[DNS名(ND):]などを確認 → [OK]をクリック


[Active Directory ユーザーとコンピューター]を閉じる


[ツール(T)]をクリック → [DNS]をクリック


左側のペインで[前方参照ゾーン]内のドメイン名 exam.local をクリック → 右側のペインで ad01 の登録内容を確認


[逆引き参照ゾーン]をクリック


メニューバーの[操作(A)]をクリック → [新しいゾーン(Z)...]をクリック


[次へ(N)]をクリック


[プライマリゾーン(P)]を選択 → [Active Directory にゾーンを格納する(A)]をチェック → [次へ(N)]をクリック


[このドメインのドメインコントローラー上で実行しているすべてのDNSサーバー(D):]を選択 → [次へ(N)]をクリック


[IPv4逆引き参照ゾーン(4)]を選択 → [次へ(N)]をクリック


[ネットワークID(E):]にネットワークアドレスを入力 → [次へ(N)]をクリック


[セキュリティで保護された動的更新のみを許可する(Active Directory用に推奨)(S)]を選択 → [次へ(N)]をクリック


[完了]をクリック


[逆引き参照ゾーン]をクリック → ゾーンが作成されたことを確認


[前方参照ゾーン]内のドメイン名 exam.local をクリック


コンピューター名を右クリック → [プロパティ(R)]をクリック


[関連付けられたポインター(PTR)レコードを更新する]をチェック → [OK]をクリック


[逆引き参照ゾーン]内のゾーン名を右クリック → [最新の情報に更新(F)]をクリック


右側のペインにコンピューター名の逆引き情報が表示されたことを確認



【参考】
Windows Server 2016 ActiveDirectoryの構築 ~ADって何だ ...
Active Directoryをインストールした後に、必要なDNSの逆引きを設定する

Windows Server 2016 : コンピューター名の変更(VMware Workstation 12 Pro)

インストール後の Windows Server 2016 のコンピューター名は適当のものになっているため変更します。変更後のコンピューター名は ad01 です。

サーバーマネージャーのダッシュボードで[ローカルサーバー]をクリック


[コンピューター名]に表示されている WIN-12EC2RAJT9R をクリック


[変更(C)...]をクリック


[コンピューター名(C):]にコンピューター名を入力 → [OK]をクリック


[OK]をクリック


[閉じる]をクリック


[今すぐ再起動する(R)]をクリック


再起動後、[コンピューター名]が変更されていることを確認


Windows Server 2016 : 評価版のインストール(VMware Workstation 12 Pro)

下図のイメージで Windows Server 2016(評価版) をインストールします。画面キャプチャは取得していませんが、ネットワークアダプタに vmxnet3 を使用しているため、インストール後の VMware Tools のインストールは必須です。Windows Update も行います。



インストールイメージの ISO ファイルで起動 → [次へ(N)]をクリック


[今すぐインストール(I)]をクリック


[Windows Server 2016 Standard Evaluation(デスクトップ エクスペリ...)]を選択 → [次へ(N)]をクリック


[同意します(A)]をチェック → [次へ(N)]をクリック


新規インストールなので[カスタム:Windowsのみをインストールする(詳細設定)(C)]をクリック


[次へ(N)]をクリック


インストール中


再起動中




管理者アカウント : Administrator のパスワードを入力 → [完了(F)]をクリック


[CTRL] + [ALT] + [DEL] を押してロックを解除


管理者アカウント : Administrator のパスワードを入力してサインイン


サインイン後にサーバーマネージャーが自動起動


VMware Tools インストール後、VyOS の DHCP で設定した IP アドレスが取得できているか確認



【参考】
Windows Server 2016 インストール手順 - ()のブログ

VyOS : DHCP で静的 IP アドレスの払い出し(VMware Workstation 12 Pro)

DHCP で MAC アドレスを元に静的に IP アドレスを払い出します。今回の設定項目です。


コマンド実行結果

vyos@gw:~$ configure
[edit]
vyos@gw# set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 static-mapping ad1 ip-address 10.1.0.101
[edit]
vyos@gw# set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 static-mapping ad1 mac-address 00:50:56:39:78:6E
[edit]
vyos@gw# commit
[edit]
vyos@gw# save
Saving configuration to '/config/config.boot'...
Done
[edit]
vyos@gw# exit
exit
vyos@gw:~$


実行結果



【参考】
vyos-users.jp - ユーザーガイド - DHCP Server

VyOS : 設定のまとめ(VMware Workstation 12 Pro)

ここまでの設定のまとめです。


set interfaces ethernet eth0 address dhcp
set interfaces ethernet eth0 description 'OUTSIDE'
set interfaces ethernet eth1 address '10.1.0.1/24'
set interfaces ethernet eth1 description 'INSIDE'

set system host-name gw
set system domain-name exam.local

set service ssh port '22'

delete system ntp server 0.pool.ntp.org
delete system ntp server 1.pool.ntp.org
delete system ntp server 2.pool.ntp.org
set system ntp server ntp.nict.jp
set system time-zone Asia/Tokyo

set service dhcp-server disabled 'false'
set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24
set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 default-router 10.1.0.1
set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 dns-server 10.1.0.1
set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 domain-name exam.local
set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 lease 86400
set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 start 10.1.0.192 stop 10.1.0.128
set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 static-mapping ad1 ip-address 10.1.0.101
set service dhcp-server shared-network-name MY_POOL subnet 10.1.0.0/24 static-mapping ad1 mac-address 00:50:56:39:78:6E

set service dns forwarding listen-on eth1

set nat source rule 100 outbound-interface eth0
set nat source rule 100 source address 10.1.0.0/24
set nat source rule 100 translation address masquerade

set firewall name OUTSIDE-IN default-action drop
set firewall name OUTSIDE-IN rule 10 action accept
set firewall name OUTSIDE-IN rule 10 state established enable
set firewall name OUTSIDE-IN rule 10 state related enable

set firewall name OUTSIDE-LOCAL default-action drop
set firewall name OUTSIDE-LOCAL rule 10 action accept
set firewall name OUTSIDE-LOCAL rule 10 state established enable
set firewall name OUTSIDE-LOCAL rule 10 state related enable
set firewall name OUTSIDE-LOCAL rule 20 action accept
set firewall name OUTSIDE-LOCAL rule 20 icmp type-name echo-request
set firewall name OUTSIDE-LOCAL rule 20 protocol icmp
set firewall name OUTSIDE-LOCAL rule 20 state new enable
set firewall name OUTSIDE-LOCAL rule 30 action accept
set firewall name OUTSIDE-LOCAL rule 30 destination port 22
set firewall name OUTSIDE-LOCAL rule 30 protocol tcp
set firewall name OUTSIDE-LOCAL rule 30 state new enable

set interfaces ethernet eth0 firewall in name OUTSIDE-IN
set interfaces ethernet eth0 firewall local name OUTSIDE-LOCAL


VyOS : ファイアウォール (FireWall:FW) の設定(VMware Workstation 12 Pro)

家庭内 LAN だとファイアウォールの設定は不要だと思いますが、練習のために設定します。設定対象は eth0 です。外 (vmnet0) 側からは icmp 応答だけを返し、LAN セグメント側からは何でも受け付ける様にします。



今回の設定項目です。


コマンド実行結果 ※ファイアウォールの設定確認まで含みます

vyos@gw:~$ configure
[edit]
vyos@gw# set firewall name OUTSIDE-IN default-action drop
[edit]
vyos@gw# set firewall name OUTSIDE-IN rule 10 action accept
[edit]
vyos@gw# set firewall name OUTSIDE-IN rule 10 state established enable
[edit]
vyos@gw# set firewall name OUTSIDE-IN rule 10 state related enable
[edit]
vyos@gw# set firewall name OUTSIDE-LOCAL default-action drop
[edit]
vyos@gw# set firewall name OUTSIDE-LOCAL rule 10 action accept
[edit]
vyos@gw# set firewall name OUTSIDE-LOCAL rule 10 state established enable
[edit]
vyos@gw# set firewall name OUTSIDE-LOCAL rule 10 state related enable
[edit]
vyos@gw# set firewall name OUTSIDE-LOCAL rule 20 action accept
[edit]
vyos@gw# set firewall name OUTSIDE-LOCAL rule 20 icmp type-name echo-request
[edit]
vyos@gw# set firewall name OUTSIDE-LOCAL rule 20 protocol icmp
[edit]
vyos@gw# set firewall name OUTSIDE-LOCAL rule 20 state new enable
[edit]
vyos@gw# set interfaces ethernet eth0 firewall in name OUTSIDE-IN
[edit]
vyos@gw# set interfaces ethernet eth0 firewall local name OUTSIDE-LOCAL
[edit]
vyos@gw# commit
[edit]
vyos@gw# save
Saving configuration to '/config/config.boot'...
Done
[edit]
vyos@gw# exit
exit
vyos@gw:~$ show firewall

-----------------------------
Rulesets Information
-----------------------------
--------------------------------------------------------------------------------
IPv4 Firewall "OUTSIDE-IN":

 Active on (eth0,IN)

rule  action   proto     packets  bytes
----  ------   -----     -------  -----
10    accept   all       0        0
  condition - saddr 0.0.0.0/0 daddr 0.0.0.0/0 state RELATED,ESTABLISHED

10000 drop     all       0        0
  condition - saddr 0.0.0.0/0 daddr 0.0.0.0/0

--------------------------------------------------------------------------------
IPv4 Firewall "OUTSIDE-LOCAL":

 Active on (eth0,LOCAL)

rule  action   proto     packets  bytes
----  ------   -----     -------  -----
10    accept   all       0        0
  condition - saddr 0.0.0.0/0 daddr 0.0.0.0/0 state RELATED,ESTABLISHED

20    accept   icmp      0        0
  condition - saddr 0.0.0.0/0 daddr 0.0.0.0/0 state NEW icmptype 8

10000 drop     all       9        2619
  condition - saddr 0.0.0.0/0 daddr 0.0.0.0/0

vyos@gw:~$



【参考】
VyOS - Firewall for WAN

VyOS : NAT の設定(VMware Workstation 12 Pro)

VyOS の NAT 機能を有効にし、PC1 がインターネットに接続できるようにします。併せてブリッジ接続している eth0 の設定と DNS 転送の設定も行います。設定後のイメージです。


今回の設定項目です。


コマンド実行結果

vyos@gw:~$ configure
[edit]
vyos@gw# set interfaces ethernet eth0 address dhcp
[edit]
vyos@gw# set interfaces ethernet eth0 description 'OUTSIDE'
[edit]
vyos@gw# set service dns forwarding listen-on eth1
[edit]
vyos@gw# set nat source rule 100 outbound-interface eth0
[edit]
vyos@gw# set nat source rule 100 source address 10.1.0.0/24
[edit]
vyos@gw# set nat source rule 100 translation address masquerade
[edit]
vyos@gw# commit
[ interfaces ethernet eth0 address dhcp ]
Starting DHCP client on eth0 ...

[ service dns forwarding ]
DNS forwarding warning: Currently, no name-servers to forward DNS queries

[edit]
vyos@gw# save
Saving configuration to '/config/config.boot'...
Done
[edit]
vyos@gw# exit
exit
vyos@gw:~$ 


PC1でブラウザを起動し、情報通信研究機構のサイトに接続した結果



【参考】
vyos-users.jp - ユーザーガイド